旗下导航:搜·么
当前位置:网站首页 > PHP框架 > Swoole > 正文

swoole仅支撑Linux体系吗【swoole】,swoole

作者:搜搜PHP网发布时间:2019-12-07分类:Swoole浏览:78


导读:swoole只能用在LInux,macos体系上,不能用作Windows体系上,Swoole2.0正式版宣布了。2.0版本最大的更新是增加了对协程(Coroutine)的...

swoole只能用在LInux,macos体系上,不能用作Windows体系上,Swoole 2.0正式版宣布了。2.0版本最大的更新是增加了对协程(Coroutine)的支撑。正式版已同时支撑PHP5和PHP7。

装置体式格局一:pecl装置 (引荐进修: swoole视频教程)

适用于php7.0以上版本

centOS中:

#pecl install swoole

报错:-bash: pecl: command not found

处理:yum install php-devel php-pear

ubuntu中:

#pecl install swoole

报错:No releases available for package "pecl.php.net/swoole"

处理:

#pear clear-cache
#pear update-channels
#pear upgrade

装置体式格局二:编译装置

适用于php5.3以上版本

centOS中:

在此网站http://pecl.php.net/package/swoole挑选适宜的版本,我用的是1.10.5

#wget http://pecl.php.net/get/swoole-1.10.5.tgz
#tar -zxvf swoole-1.10.5.tgz
#cd swoole-1.10.5
#phpize
#./configure
#make
#make install

在php.ini到场一行:extension=swoole.so

重启apache,#systemctl restart httpd.service

经由过程php -m或phpinfo检察是不是装置胜利

ubuntu中:

报错:没有phpize

处理:#sudo apt-get install php5.6-dev //我的是php5.6

其他同centOS相似

重启apache,#/etc/init.d/apache2 restar

以上就是swoole仅支撑Linux体系吗的细致内容,更多请关注ki4网别的相干文章!

标签:swoole