旗下导航:搜·么
当前位置:网站首页 > PHP框架 > YII > 正文

怎样装置yii2.0【yii框架教程】,安装,yii2.0

作者:搜搜PHP网发布时间:2019-12-10分类:YII浏览:121


导读:1、装置环境由于Yii框架须要PHP5.5以上版本支撑,所以先把你的PHP5.3卸载了吧,假如以为关联太多不想贫苦,痛快把PHP、MySQL、Apache都删清洁,然后...

1、装置环境

由于Yii框架须要PHP5.5以上版本支撑,所以先把你的PHP5.3卸载了吧,假如以为关联太多不想贫苦,痛快把PHP、MySQL、Apache都删清洁,然后一个phpStudy2016悉数搞定。

2、装置Composer

双击Composer.exe,然后点击Next,

点击Browser手动挑选php.exe的装置途径(有的版本会自动寻觅php.exe的装置途径),由于这里用的是集成环境PHPStudy,且版本切换到了5.5版本,所以挑选如上图,然后点击Next,

勾选唯一选项,然后点击Next,

这一步是设置前缀,不必管,直接点击Next,

点击Install入手下手装置,

点击Next,点击Next,点击Next,点击Finish,至此完成!

3、装置Yii框架

Yii框架和之前的框架差别,须要装置。下载Yii框架(或运用他人下载好的装置包,有两个版本basic和advanced,本例采纳basic),解压后把文件包放入服务器的项目根目录下(本例为D:\PhpStudy\WWW)。

要领一(基本版和高等版都可以用)

翻开config文件夹下的web.config文件,找到cookieValidationKey

随意到场一串暗码,比方123456,然后保留。进入浏览器,在列表形式下逐渐点击进入以下地点:

http://www.xueqiyao.com/Yii/advanced/frontend/web/

涌现以下界面申明装置胜利。

要领二(仅用于高等版)

翻开cmd,输入d:进入D盘,然后进入到advanced文件夹下,D:\> cd PhpStudy\WWW\advanced,进入以后输入init示意初始化,回车,有大概提醒The OpenSSL PHP extensioin is required by Yii,这时候翻开php.ini文件找到extension=php_openssl.dll把前面的解释去掉,再次返回实行init敕令,弹出选项,输入0(示意挑选开发环境),弹出选项,输入yes回车,末了涌现completed示意装置完成。);变动common/config/main-local.php里的‘db’,衔接数据库,再在cmd敕令行里实行php yii migrate敕令,可在衔接的数据库里自动生成user表。

ki4网,有大批免费的Yii入门教程,迎接人人进修!

以上就是怎样装置yii2.0的细致内容,更多请关注ki4网别的相干文章!

标签:安装yii2.0