旗下导航:搜·么
当前位置:网站首页 > PHP框架 > YII > 正文

yii框架怎样装置?【yii框架教程】,yii

作者:搜搜PHP网发布时间:2019-12-25分类:YII浏览:74


导读:Yii是一个高性能的PHP5的web应用程序开发框架。经由过程一个简朴的敕令行东西yiic能够疾速建立一个web应用程序的代码框架,开发者能够在生成的代码框架基础上增加营业逻辑...
Yii是一个高性能的PHP5的web应用程序开发框架。经由过程一个简朴的敕令行东西 yiic 能够疾速建立一个web应用程序的代码框架,开发者能够在生成的代码框架基础上增加营业逻辑,以疾速完成应用程序的开发。

yii框架怎样装置?

我们能够经由过程Composer来装置Yii。

Composer 是 PHP5.3以上 的一个依靠治理东西。它许可你声明项目所依靠的代码库,它会在你的项目中为你装置他们。Composer 不是一个包治理器。是的,它触及 "packages" 和 "libraries",但它在每一个项目的基础上举行治理,在你项目的某个目次中(比方 vendor)举行装置。默许情况下它不会在全局装置任何东西。因而,这仅仅是一个依靠治理。

步骤:

1、装置 Composer

假如还没有装置 Composer,你能够按 getcomposer.org 中的要领装置。

在 Linux 和 Mac OS X 中能够运转以下敕令:

curl -sS https://getcomposer.org/installer | php
mv composer.phar /usr/local/bin/composer

在 Windows 中,你须要下载并运转 Composer-Setup.exe。

假如碰到任何问题或许想更深切地进修 Composer。 假如你已装置有 Composer 请确保运用的是最新版本, 你能够用 composer self-update 敕令更新 Composer 为最新版本。

一切 composer 敕令都假定您已装置了全局的 composer, 如许它能够作为 composer 敕令。假如您在当地目次中运用 composer.phar, 则必需响应地调解示例敕令。

假如您之前已装置 Composer,请确保运用最新版本。 您能够经由过程运转 composer self-update 来更新Composer。

2、装置 Yii

装置Composer后,您能够经由过程在 Web 可接见的文件夹下运转以下敕令来装置Yii应用程序模板:

composer create-project --prefer-dist yiisoft/yii2-app-basic basic

这将在一个名为 basic 的目次中装置Yii应用程序模板的最新稳固版本。 假如须要,您能够挑选差别的目次称号。

提醒: 假如你想装置 Yii 的最新开发版本,能够运用以下敕令替代, 它增加了一个 stability 选项

composer create-project --prefer-dist --stability=dev yiisoft/yii2-app-basic basic

请注意,Yii的开发版本不应该用于生产,由于它可能会损坏您的运转代码。

引荐进修:Yii入门教程

以上就是yii框架怎样装置?的细致内容,更多请关注ki4网别的相干文章!

标签:yii